Unable to resolve dependency 'Microsoft.AspNet.WebApi.Client (≥ 2.0.20710.0 && < 2.1)'.

Topics: ASP.NET Web API, ASP.NET Web Pages, General
Sep 25, 2012 at 10:51 AM

 

When I tried to install a System.Net.HttpFormatting package from Nuget package manager

I am getting the below error..

Unable to resolve dependency 'Microsoft.AspNet.WebApi.Client (≥ 2.0.20710.0 && < 2.1)'.

 

Coordinator
Sep 25, 2012 at 4:43 PM

You should just install the Microsoft.AspNet.WebApi.Client package directly. The old System.Net.Http.Formatting package is there only for legacy purposes.

Daniel Roth